Skip to content

← Actionable
Medium, CVSS 4.8

XWiki Platform Security Authorization Bridge allows users with just edit right can enforce required rights with programming right

CVE-2025-48063GHSA-rhfv-688c-p6hp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-security-authorization-bridge 17.1.0-rc-1, 16.10.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-rhfv-688c-p6hp lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-authorization-bridge >=16.10.0-rc-1 =17.0.0-rc-1 <17.1.0-rc-1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-48063: 1.03% estimated exploitation activity in the next 30 days; percentile 63.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In XWiki 16.10.0, required rights were introduced as a way to limit which rights a document can have. Part of the security model of required rights is that a user who doesn't have a right also cannot define that right as required right. That way, users who are editing documents on which required rights are enforced can be sure that they're not giving a right to a script or object that it didn't have before. A bug in the implementation of the enforcement of this rule means that in fact, it was possible for any user with edit right on a document to set programming right as required right. If then a user with programming right edited that document, the content of that document would gain programming right, allowing remote code execution. This thereby defeats most of the security benefits of required rights. As XWiki still performs the required rights analysis when a user edits a page even when required rights are enforced, the user with programming right would still be warned…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rhfv-688c-p6hp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48063

Advisory: XWiki Platform Security Authorization Bridge allows users with just edit right can enforce required rights with programming right
IDs: CVE-2025-48063, GHSA-rhfv-688c-p6hp
Record: https://patchnext.com/advisories/cve-2025-48063 (revision 1, source checked 26 Oct 2026, 16:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-security-authorization-bridge 17.1.0-rc-1, 16.10.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-security-authorization-bridge: affected >= 16.10.0-rc-1, < 16.10.4; >= 17.0.0-rc-1, < 17.1.0-rc-1; fixed in 17.1.0-rc-1, 16.10.4

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-security-authorization-bridge: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-security-authorization-bridge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rhfv-688c-p6hp (GitHub-reviewed advisory GHSA-rhfv-688c-p6hp lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-authorization-bridge >=16.10.0-rc-1 =17.0.0-rc-1 <17.1.0-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…