PowSyBl Core Contains a Polynomial ReDoS in RegexCriterion
CVE-2025-48059GHSA-8qjw-9xgm-c9ff
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.powsybl:powsybl-contingency-api 6.3.0; com.powsybl:powsybl-iidm-criteria 6.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.powsybl:powsybl-contingency-api
- Affected
- >= 5.0.0, < 6.3.0
- Fixed in
- 6.3.0
Maven com.powsybl:powsybl-iidm-criteria
- Affected
- >= 6.3.0, <= 6.7.1
- Fixed in
- 6.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8qjw-9xgm-c9ff lists affected ranges: Maven com.powsybl:powsybl-iidm-criteria >=6.3.0 =5.0.0 <6.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-48059: 0.57% estimated exploitation activity in the next 30 days; percentile 47.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? This is an advisory for a potential polynomial Regular Expression Denial of Service (ReDoS) vulnerability in the RegexCriterion class. This class compiles and evaluates an unvalidated, user-supplied regular expression against the identifier of an Identifiable object via Pattern.compile(regex).matcher(id).find(). To trigger polynomial ReDoS in RegexCriterion, two attacker-controlled conditions must be met: - Control over the regex input passed into the constructor: - Example: An attacker supplies a malicious pattern such as (.a){10000}. - Control or influence over the output of Identifiable.getId(): - Example: A long string like "aaaa...!" that forces excessive backtracking. If both conditions are satisfied, a malicious actor can cause significant CPU exhaustion through repeated or recursive filter(...) calls — especially if performed over large network models or filtering operations. While this class does not handle file or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8qjw-9xgm-c9ff
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48059 Advisory: PowSyBl Core Contains a Polynomial ReDoS in RegexCriterion IDs: CVE-2025-48059, GHSA-8qjw-9xgm-c9ff Record: https://patchnext.com/advisories/cve-2025-48059 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.powsybl:powsybl-contingency-api 6.3.0; com.powsybl:powsybl-iidm-criteria 6.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.powsybl:powsybl-contingency-api: affected >= 5.0.0, < 6.3.0; fixed in 6.3.0 - Maven com.powsybl:powsybl-iidm-criteria: affected >= 6.3.0, <= 6.7.1; fixed in 6.7.2 ## Suggested inspection (read-only) - Maven com.powsybl:powsybl-contingency-api: check the installed version with your package manager. - Maven com.powsybl:powsybl-iidm-criteria: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.powsybl:powsybl-contingency-api, com.powsybl:powsybl-iidm-criteria. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8qjw-9xgm-c9ff (GitHub-reviewed advisory GHSA-8qjw-9xgm-c9ff lists affected ranges: Maven com.powsybl:powsybl-iidm-criteria >=6.3.0 =5.0.0 <6.3.0) Commands are suggestions: review each one before running it.
Loading voting…