PowSyBl Core contains Polynomial REDoS’es
CVE-2025-48058GHSA-rqpx-f6rc-7hm5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.powsybl:powsybl-commons 6.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.powsybl:powsybl-commons
- Affected
- <= 6.7.1
- Fixed in
- 6.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rqpx-f6rc-7hm5 lists affected ranges: Maven com.powsybl:powsybl-commons >=0 <=6.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-48058: 0.41% estimated exploitation activity in the next 30 days; percentile 35.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? This is an advisory for a potential polynomial Regular Expression Denial of Service (ReDoS) vulnerability in the PowSyBl's DataSource mechanism. When the listNames(String regex) method is called on a DataSource, the user-supplied regular expression (which may be unvalidated) is compiled and evaluated against a collection of file-like resource names. To trigger a polynomial ReDoS via this mechanism, two attacker-controlled conditions must be met: - Control over the regex input passed into listNames(String regex). - Example: An attacker supplies a malicious pattern like (.a){10000}. - Control or influence over the file/resource names being matched. - Example: Filenames such as "aaaa...!" that induce regex engine backtracking. If both conditions are satisfied, a malicious actor can cause significant CPU consumption due to regex backtracking — even with polynomial patterns. Since both inputs can be controlled via a publicly…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rqpx-f6rc-7hm5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-48058 Advisory: PowSyBl Core contains Polynomial REDoS’es IDs: CVE-2025-48058, GHSA-rqpx-f6rc-7hm5 Record: https://patchnext.com/advisories/cve-2025-48058 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.powsybl:powsybl-commons 6.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.powsybl:powsybl-commons: affected <= 6.7.1; fixed in 6.7.2 ## Suggested inspection (read-only) - Maven com.powsybl:powsybl-commons: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.powsybl:powsybl-commons. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rqpx-f6rc-7hm5 (GitHub-reviewed advisory GHSA-rqpx-f6rc-7hm5 lists affected ranges: Maven com.powsybl:powsybl-commons >=0 <=6.7.1) Commands are suggestions: review each one before running it.
Loading voting…