Skip to content

← Actionable
Medium, CVSS 6.5amended

Cocotais Bot has builtin .echo command injection

CVE-2025-47948GHSA-mj2c-8hxf-ffvq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cocotais-bot 1.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm cocotais-bot

    Affected
    >= 1.5.0-test2-hotfix, < 1.6.2
    Fixed in
    1.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
EPSS
  • CVE-2025-47948: 0.41% estimated exploitation activity in the next 30 days; percentile 35.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A command echoing feature in the framework allows users to indirectly trigger privileged behavior by injecting special platform tags. Specifically, an unauthorized user can use the /echo <qqbot-at-everyone / command to cause the bot to send a message that mentions all members in the chat, bypassing any permission controls. This can lead to spam, disruption, or abuse of notification systems. Details The framework provides a command /echo that causes the bot to repeat any user-provided message verbatim in the group chat. However, the bot fails to sanitize or filter platform-specific control elements such as <qqbot-at-everyone /, which, when included in a message, mentions everyone (i.e., @全体成员). While normal users are forbidden from using this tag in normal chats, the bot, which has higher privileges, is allowed to do so. Since the /echo command blindly echoes any content, a user can exploit this by sending: The bot will then send a message containing <qqbot-at-everyone /,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mj2c-8hxf-ffvq

  2. Revision 1 · created ·

    Published from osv record GHSA-mj2c-8hxf-ffvq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-47948

Advisory: Cocotais Bot has builtin .echo command injection
IDs: CVE-2025-47948, GHSA-mj2c-8hxf-ffvq
Record: https://patchnext.com/advisories/cve-2025-47948 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cocotais-bot 1.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm cocotais-bot: affected >= 1.5.0-test2-hotfix, < 1.6.2; fixed in 1.6.2

## Suggested inspection (read-only)
- `npm ls cocotais-bot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cocotais-bot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mj2c-8hxf-ffvq (OSV record GHSA-mj2c-8hxf-ffvq lists affected ranges: npm cocotais-bot >=1.5.0-test2-hotfix <1.6.2 (fixed))
- Verified: https://github.com/advisories/GHSA-mj2c-8hxf-ffvq (GitHub-reviewed advisory GHSA-mj2c-8hxf-ffvq lists affected ranges: npm cocotais-bot >=1.5.0-test2-hotfix <1.6.2)

Commands are suggestions: review each one before running it.

Loading voting…