Gogs XSS allowed by stored call in PDF renderer
CVE-2025-47943GHSA-xh32-cx6c-cp4v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gogs/gogs 0.13.3-0.20250608224432-110117b2e5e5; gogs.io/gogs 0.13.3-0.20250608224432-110117b2e5e5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.13.3-0.20250608224432-110117b2e5e5
- Fixed in
- 0.13.3-0.20250608224432-110117b2e5e5
Go gogs.io/gogs
- Affected
- < 0.13.3-0.20250608224432-110117b2e5e5
- Fixed in
- 0.13.3-0.20250608224432-110117b2e5e5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xh32-cx6c-cp4v lists affected ranges: Go github.com/gogs/gogs >=0 =0 <0.13.3-0.20250608224432-110117b2e5e5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2025-47943: 0.40% estimated exploitation activity in the next 30 days; percentile 33.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored XSS is present in Gogs which allows client-side Javascript code execution. Details Gogs Version: Application version: 0.14.0+dev Local setup using: The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. Read more about this vulnerability at codeanlabs - CVE-2024-4367. PoC 1. Upload the Proof of Concept file hosted at https://codeanlabs.com/wp-content/uploads/2024/05/pocgeneralizedCVE-2024-4367.pdf in a repository. 2. Click on the file to be previewed. Credits Edoardo Ottavianelli
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xh32-cx6c-cp4v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47943 Advisory: Gogs XSS allowed by stored call in PDF renderer IDs: CVE-2025-47943, GHSA-xh32-cx6c-cp4v Record: https://patchnext.com/advisories/cve-2025-47943 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/gogs/gogs 0.13.3-0.20250608224432-110117b2e5e5; gogs.io/gogs 0.13.3-0.20250608224432-110117b2e5e5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/gogs/gogs: affected < 0.13.3-0.20250608224432-110117b2e5e5; fixed in 0.13.3-0.20250608224432-110117b2e5e5 - Go gogs.io/gogs: affected < 0.13.3-0.20250608224432-110117b2e5e5; fixed in 0.13.3-0.20250608224432-110117b2e5e5 ## Suggested inspection (read-only) - Go github.com/gogs/gogs: check the installed version with your package manager. - Go gogs.io/gogs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/gogs/gogs, gogs.io/gogs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xh32-cx6c-cp4v (GitHub-reviewed advisory GHSA-xh32-cx6c-cp4v lists affected ranges: Go github.com/gogs/gogs >=0 =0 <0.13.3-0.20250608224432-110117b2e5e5) Commands are suggestions: review each one before running it.
Loading voting…