Skip to content

← Actionable
Low, CVSS 3.8

TYPO3 Unverified Password Change for Backend Users

CVE-2025-47938GHSA-3jrg-97f3-rqh9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-setup 13.4.12, 12.4.31, 11.5.44, 10.4.50, 9.5.51; typo3/cms-core 13.4.12, 12.4.31, 11.5.44, 10.4.50, 9.5.51), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-setup

    Affected
    >= 9.0.0, <= 9.5.50>= 10.0.0, <= 10.4.49>= 11.0.0, <= 11.5.43>= 12.0.0, <= 12.4.30>= 13.0.0, <= 13.4.11
    Fixed in
    13.4.12, 9.5.51, 10.4.50, 11.5.44, 12.4.31
  • Packagist typo3/cms-core

    Affected
    >= 9.0.0, <= 9.5.50>= 10.0.0, <= 10.4.49>= 11.0.0, <= 11.5.43>= 12.0.0, <= 12.4.30>= 13.0.0, <= 13.4.11
    Fixed in
    13.4.12, 9.5.51, 10.4.50, 11.5.44, 12.4.31

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-3jrg-97f3-rqh9 lists affected ranges: Packagist typo3/cms-core >=9.0.0 =10.0.0 =11.0.0 =12.0.0 =13.0.0 =9.0.0 =10.0.0 =11.0.0 =12.0.0 =13.0.0 <=13.4.11

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-47938: 0.27% estimated exploitation activity in the next 30 days; percentile 20.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Problem The backend user management interface allows password changes without requiring the current password. When an administrator updates their own account or modifies other user accounts via the admin interface, the current password is not requested for verification. This behavior may lower the protection against unauthorized access in scenarios where an admin session is hijacked or left unattended, as it enables password changes without additional authentication. Solution Update to TYPO3 versions 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, 13.4.12 LTS that fix the problem described. [!NOTE] In these versions, administrators are required to verify their identity through step-up authentication (also known as sudo mode) when changing backend user passwords. Credits Thanks to the National Cyber Security Center (NCSC) of Switzerland for reporting this issue, and to TYPO3 core & security team member Benjamin Franzke for fixing it.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3jrg-97f3-rqh9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-47938

Advisory: TYPO3 Unverified Password Change for Backend Users
IDs: CVE-2025-47938, GHSA-3jrg-97f3-rqh9
Record: https://patchnext.com/advisories/cve-2025-47938 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-setup 13.4.12, 12.4.31, 11.5.44, 10.4.50, 9.5.51; typo3/cms-core 13.4.12, 12.4.31, 11.5.44, 10.4.50, 9.5.51. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-setup: affected >= 9.0.0, <= 9.5.50; >= 10.0.0, <= 10.4.49; >= 11.0.0, <= 11.5.43; >= 12.0.0, <= 12.4.30; >= 13.0.0, <= 13.4.11; fixed in 13.4.12, 9.5.51, 10.4.50, 11.5.44, 12.4.31
- Packagist typo3/cms-core: affected >= 9.0.0, <= 9.5.50; >= 10.0.0, <= 10.4.49; >= 11.0.0, <= 11.5.43; >= 12.0.0, <= 12.4.30; >= 13.0.0, <= 13.4.11; fixed in 13.4.12, 9.5.51, 10.4.50, 11.5.44, 12.4.31

## Suggested inspection (read-only)
- Packagist typo3/cms-setup: check the installed version with your package manager.
- Packagist typo3/cms-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-setup, typo3/cms-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3jrg-97f3-rqh9 (GitHub-reviewed advisory GHSA-3jrg-97f3-rqh9 lists affected ranges: Packagist typo3/cms-core >=9.0.0 =10.0.0 =11.0.0 =12.0.0 =13.0.0 =9.0.0 =10.0.0 =11.0.0 =12.0.0 =13.0.0 <=13.4.11)

Commands are suggestions: review each one before running it.

Loading voting…