LibreNMS stored Cross-site Scripting vulnerability in poller group name
CVE-2025-47931GHSA-hxw5-9cc5-cmw5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 25.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- < 25.5.0
- Fixed in
- 25.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hxw5-9cc5-cmw5 lists affected ranges: Packagist librenms/librenms >=0 <25.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P · score source
- EPSS
- CVE-2025-47931: 10.12% estimated exploitation activity in the next 30 days; percentile 95.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
LibreNMS v25.4.0 suffers from Stored Cross-Site Scripting (XSS) Vulnerability in the 'group name' parameter of the 'http://localhost/poller/groups' form. This vulnerability allows attackers to inject malicious scripts into web pages viewed by other users. ---------------------------------POC----------------------------- Before Setting: Enable 'distributedpoller' in http://localhost/settings/poller/distributed 1. Attacker creates a new poller group and injects the payload in the 'group name' parameter 2. Victim navigates to the 'http://localhost/addhost' to add a new host 3. The payload is executed code sink: https://github.com/librenms/librenms/blob/25.4.0/includes/html/pages/addhost.inc.php#L284
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hxw5-9cc5-cmw5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47931 Advisory: LibreNMS stored Cross-site Scripting vulnerability in poller group name IDs: CVE-2025-47931, GHSA-hxw5-9cc5-cmw5 Record: https://patchnext.com/advisories/cve-2025-47931 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 25.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist librenms/librenms: affected < 25.5.0; fixed in 25.5.0 ## Suggested inspection (read-only) - Packagist librenms/librenms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on librenms/librenms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hxw5-9cc5-cmw5 (GitHub-reviewed advisory GHSA-hxw5-9cc5-cmw5 lists affected ranges: Packagist librenms/librenms >=0 <25.5.0) Commands are suggestions: review each one before running it.
Loading voting…