Denial of service via malicious preflight requests in github.com/rs/cors
CVE-2025-47908GHSA-mh55-gqvf-xfwm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rs/cors 1.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.9.0, < 1.11.0
- Fixed in
- 1.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mh55-gqvf-xfwm lists affected ranges: Go github.com/rs/cors >=1.9.0 <1.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2025-47908: 0.63% estimated exploitation activity in the next 30 days; percentile 50.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Middleware causes a prohibitive amount of heap allocations when processing malicious preflight requests that include a Access-Control-Request-Headers (ACRH) header whose value contains many commas. This behavior can be abused by attackers to produce undue load on the middleware/server as an attempt to cause a denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mh55-gqvf-xfwm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47908 Advisory: Denial of service via malicious preflight requests in github.com/rs/cors IDs: CVE-2025-47908, GHSA-mh55-gqvf-xfwm Record: https://patchnext.com/advisories/cve-2025-47908 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rs/cors 1.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rs/cors: affected >= 1.9.0, < 1.11.0; fixed in 1.11.0 ## Suggested inspection (read-only) - Go github.com/rs/cors: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rs/cors. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mh55-gqvf-xfwm (GitHub-reviewed advisory GHSA-mh55-gqvf-xfwm lists affected ranges: Go github.com/rs/cors >=1.9.0 <1.11.0) Commands are suggestions: review each one before running it.
Loading voting…