label-studio vulnerable to Cross-Site Scripting (Reflected) via the label_config parameter.
CVE-2025-47783GHSA-8jhr-wpcm-hh4h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (label-studio 1.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI label-studio
- Affected
- < 1.18.0
- Fixed in
- 1.18.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8jhr-wpcm-hh4h lists affected ranges: PyPI label-studio >=0 <1.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8jhr-wpcm-hh4h lists affected ranges: PyPI label-studio >=0 <1.18.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-47783: 0.60% estimated exploitation activity in the next 30 days; percentile 48.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The vulnerability allows an attacker to inject a malicious script into the context of a web page, which can lead to data theft, unauthorized actions on behalf of the user, and other attacks. Details The vulnerability is reproducible when sending a properly formatted request to the POST /projects/upload-example/ endpoint. In the source code, the vulnerability is located at labelstudio/projects/views.py. The vulnerability is specifically located in line 57, where HttpResponse is used. PoC Send the following request after changing the {host} to your own. Or you can create a vulnerable HTML page by changing {domain} beforehand, which can later be sent to the victim. Impact - Malicious code execution: The user may be forced to perform unwanted actions within their Label Studio account. This includes accessing document.cookie, but note that Label Studio session cookies are marked http-only, mitigating any possibility of session theft.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8jhr-wpcm-hh4h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8jhr-wpcm-hh4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47783 Advisory: label-studio vulnerable to Cross-Site Scripting (Reflected) via the label_config parameter. IDs: CVE-2025-47783, GHSA-8jhr-wpcm-hh4h Record: https://patchnext.com/advisories/cve-2025-47783 (revision 3, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: label-studio 1.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI label-studio: affected < 1.18.0; fixed in 1.18.0 ## Suggested inspection (read-only) - `python -m pip show label-studio`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on label-studio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8jhr-wpcm-hh4h (OSV record GHSA-8jhr-wpcm-hh4h lists affected ranges: PyPI label-studio >=0 <1.18.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8jhr-wpcm-hh4h (GitHub-reviewed advisory GHSA-8jhr-wpcm-hh4h lists affected ranges: PyPI label-studio >=0 <1.18.0) Commands are suggestions: review each one before running it.
Loading voting…