motionEye vulnerable to RCE in add_camera Function Due to unsafe command execution
CVE-2025-47782GHSA-g5mq-prx7-c588
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (motioneye 0.43.1b4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI motioneye
- Affected
- >= 0.43.1b1, < 0.43.1b4
- Fixed in
- 0.43.1b4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g5mq-prx7-c588 lists affected ranges: PyPI motioneye >=0.43.1b1 <0.43.1b4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g5mq-prx7-c588 lists affected ranges: PyPI motioneye >=0.43.1b1 <0.43.1b4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-47782: 0.51% estimated exploitation activity in the next 30 days; percentile 43.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Using a constructed (camera) device path with the config/add/addcamera motionEye web API allows an attacker with motionEye admin user credentials to execute any UNIX shell code within a non-interactive shell as executing user of the motionEye instance, motion by default. function call stack 1. post 2. addcamera 3. config.addcamera 4. v4l2ctl.listresolutions 5. utils.callsubprocess 6. subprocess.run PoC build reproduce Run: Now, run the following script to attack motionEye: <img width="1187" alt="Image" src="https://github.com/user-attachments/assets/8e0a9bfe-8de3-4023-96d6-0e888bfe3c62" / <img width="324" alt="Image" src="https://github.com/user-attachments/assets/04c73349-694a-4531-993e-eea765b87d0e" / Discussion It is obvious that callsubprocess was used to execute the incoming data, resulting in a vulnerability Impact RCE Patches The vulnerability has been patch with motionEye v0.43.1b4: https://github.com/motioneye-project/motioneye/pull/3143 Workarounds Applying the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g5mq-prx7-c588
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-g5mq-prx7-c588
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47782 Advisory: motionEye vulnerable to RCE in add_camera Function Due to unsafe command execution IDs: CVE-2025-47782, GHSA-g5mq-prx7-c588 Record: https://patchnext.com/advisories/cve-2025-47782 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: motioneye 0.43.1b4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI motioneye: affected >= 0.43.1b1, < 0.43.1b4; fixed in 0.43.1b4 ## Suggested inspection (read-only) - `python -m pip show motioneye`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on motioneye. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g5mq-prx7-c588 (OSV record GHSA-g5mq-prx7-c588 lists affected ranges: PyPI motioneye >=0.43.1b1 <0.43.1b4 (fixed)) - Verified: https://github.com/advisories/GHSA-g5mq-prx7-c588 (GitHub-reviewed advisory GHSA-g5mq-prx7-c588 lists affected ranges: PyPI motioneye >=0.43.1b1 <0.43.1b4) Commands are suggestions: review each one before running it.
Loading voting…