PowSyBl Core allows deserialization of untrusted SparseMatrix data
CVE-2025-47771GHSA-f5cx-h789-j959
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.powsybl:powsybl-math 6.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.powsybl:powsybl-math
- Affected
- >= 6.3.0, <= 6.7.1
- Fixed in
- 6.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f5cx-h789-j959 lists affected ranges: Maven com.powsybl:powsybl-math >=6.3.0 <=6.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-47771: 0.52% estimated exploitation activity in the next 30 days; percentile 43.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? This is a disclosure for a security vulnerability in the SparseMatrix class. The vulnerability is a deserialization issue that can lead to a wide range of privilege escalations depending on the circumstances. The problematic area is the read method of the SparseMatrix class. This method takes in an InputStream and returns a SparseMatrix object. We consider this to be a method that can be exposed to untrusted input in at least two use cases: - A user can adopt this method in an application where users can submit an InputStream and the application parses it into a SparseMatrix. This can be a multi-tenant application that hosts many different users perhaps with different privilege levels. - A user adopts the method for a local tool but receives the InputStream from external sources. Am I impacted? You are vulnerable if you import non-controlled serialized SparseMatrix objects. Patches com.powsybl:powsybl-math:6.7.2 and higher…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f5cx-h789-j959
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47771 Advisory: PowSyBl Core allows deserialization of untrusted SparseMatrix data IDs: CVE-2025-47771, GHSA-f5cx-h789-j959 Record: https://patchnext.com/advisories/cve-2025-47771 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.powsybl:powsybl-math 6.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.powsybl:powsybl-math: affected >= 6.3.0, <= 6.7.1; fixed in 6.7.2 ## Suggested inspection (read-only) - Maven com.powsybl:powsybl-math: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.powsybl:powsybl-math. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f5cx-h789-j959 (GitHub-reviewed advisory GHSA-f5cx-h789-j959 lists affected ranges: Maven com.powsybl:powsybl-math >=6.3.0 <=6.7.1) Commands are suggestions: review each one before running it.
Loading voting…