PowSyBl Core XML Reader allows XXE and SSRF
CVE-2025-47293GHSA-qpj9-qcwx-8jv2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.powsybl:powsybl-commons 6.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.powsybl:powsybl-commons
- Affected
- <= 6.7.1
- Fixed in
- 6.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qpj9-qcwx-8jv2 lists affected ranges: Maven com.powsybl:powsybl-commons >=0 <=6.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-47293: 0.44% estimated exploitation activity in the next 30 days; percentile 38.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? In certain places, powsybl-core XML parsing is vulnerable to an XXE attack and in on place also to an SSRF attack. This allows an attacker to elevate their privileges to read files that they do not have permissions to, including sensitive files on the system. The vulnerable class is com.powsybl.commons.xml.XmlReader which is considered to be untrusted in use cases where untrusted users can submit their XML to the vulnerable methods. This can be a multi-tenant application that hosts many different users perhaps with different privilege levels. Am I impacted? You are vulnerable if you allow untrusted users to import untrusted CGMES or XIIDM network files. Patches com.powsybl:powsybl-commons:6.7.2 and higher References powsybl-core v6.7.2
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qpj9-qcwx-8jv2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47293 Advisory: PowSyBl Core XML Reader allows XXE and SSRF IDs: CVE-2025-47293, GHSA-qpj9-qcwx-8jv2 Record: https://patchnext.com/advisories/cve-2025-47293 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.powsybl:powsybl-commons 6.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.powsybl:powsybl-commons: affected <= 6.7.1; fixed in 6.7.2 ## Suggested inspection (read-only) - Maven com.powsybl:powsybl-commons: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.powsybl:powsybl-commons. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qpj9-qcwx-8jv2 (GitHub-reviewed advisory GHSA-qpj9-qcwx-8jv2 lists affected ranges: Maven com.powsybl:powsybl-commons >=0 <=6.7.1) Commands are suggestions: review each one before running it.
Loading voting…