Skip to content

← Actionable
Low, CVSS 1.8amended

Flask uses fallback key instead of current signing key

CVE-2025-47278GHSA-4grg-w6v8-c28g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask 3.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI flask

    Affected
    >= 3.1.0, <= 3.1.0
    Fixed in
    3.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-47278: 0.19% estimated exploitation activity in the next 30 days; percentile 8.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Flask 3.1.0, the way fallback key configuration was handled resulted in the last fallback key being used for signing, rather than the current signing key. Signing is provided by the itsdangerous library. A list of keys can be passed, and it expects the last (top) key in the list to be the most recent key, and uses that for signing. Flask was incorrectly constructing that list in reverse, passing the signing key first. Sites that have opted-in to use key rotation by setting SECRETKEYFALLBACKS are likely to unexpectedly be signing their sessions with stale keys, and their transition to fresher keys will be impeded. Sessions are still signed, so this would not cause any sort of data integrity loss.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4grg-w6v8-c28g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4grg-w6v8-c28g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-47278

Advisory: Flask uses fallback key instead of current signing key
IDs: CVE-2025-47278, GHSA-4grg-w6v8-c28g
Record: https://patchnext.com/advisories/cve-2025-47278 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flask 3.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flask: affected >= 3.1.0, <= 3.1.0; fixed in 3.1.1

## Suggested inspection (read-only)
- `python -m pip show flask`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flask.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4grg-w6v8-c28g (OSV record GHSA-4grg-w6v8-c28g lists affected ranges: PyPI flask >=3.1.0 <3.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-4grg-w6v8-c28g (GitHub-reviewed advisory GHSA-4grg-w6v8-c28g lists affected ranges: PyPI flask >=3.1.0 <=3.1.0)

Commands are suggestions: review each one before running it.

Loading voting…