Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK
CVE-2025-47275GHSA-g98g-r7gf-2r25
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/auth0-php 8.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist auth0/auth0-php
- Affected
- >= 8.0.0-BETA1, < 8.14.0
- Fixed in
- 8.14.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g98g-r7gf-2r25 lists affected ranges: Packagist auth0/auth0-php >=8.0.0-BETA1 <8.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-47275: 0.54% estimated exploitation activity in the next 30 days; percentile 45.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview Session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Am I Affected? You are affected by this vulnerability if you meet the following pre-conditions: 1. Applications using the Auth0-PHP SDK, or the following SDKs that rely on the Auth0-PHP SDK: a. Auth0/symfony, b. Auth0/laravel-auth0, c. Auth0/wordpress, 2. Session storage configured with CookieStore. Fix Upgrade Auth0/Auth0-PHP to v8.14.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected. Acknowledgement Okta would like to thank Félix Charette for discovering this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g98g-r7gf-2r25
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47275 Advisory: Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK IDs: CVE-2025-47275, GHSA-g98g-r7gf-2r25 Record: https://patchnext.com/advisories/cve-2025-47275 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: auth0/auth0-php 8.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist auth0/auth0-php: affected >= 8.0.0-BETA1, < 8.14.0; fixed in 8.14.0 ## Suggested inspection (read-only) - Packagist auth0/auth0-php: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on auth0/auth0-php. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g98g-r7gf-2r25 (GitHub-reviewed advisory GHSA-g98g-r7gf-2r25 lists affected ranges: Packagist auth0/auth0-php >=8.0.0-BETA1 <8.14.0) Commands are suggestions: review each one before running it.
Loading voting…