Skip to content

← Actionable
High, CVSS 7.7amended

setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write

CVE-2025-47273GHSA-5rjg-fvgr-3xxf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (setuptools 78.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-47273: 1.59% estimated exploitation activity in the next 30 days; percentile 75.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability in PackageIndex was fixed in setuptools version 78.1.1 Details Here: https://github.com/pypa/setuptools/blob/6ead555c5fb29bc57fe6105b1bffc163f56fd558/setuptools/packageindex.py#L810C1-L825C88 os.path.join() discards the first argument tmpdir if the second begins with a slash or drive letter. name is derived from a URL without sufficient sanitization. While there is some attempt to sanitize by replacing instances of '..' with '.', it is insufficient. Risk Assessment As easyinstall and packageindex are deprecated, the exploitation surface is reduced. However, it seems this could be exploited in a similar fashion like https://github.com/advisories/GHSA-r9hx-vwmv-q579, and as described by POC 4 in https://github.com/advisories/GHSA-cx63-2mw6-8hw5 report: via malicious URLs present on the pages of a package index. Impact An attacker would be allowed to write files to arbitrary locations on the filesystem with the permissions of the process running…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5rjg-fvgr-3xxf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5rjg-fvgr-3xxf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-47273

Advisory: setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write
IDs: CVE-2025-47273, GHSA-5rjg-fvgr-3xxf
Record: https://patchnext.com/advisories/cve-2025-47273 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: setuptools 78.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI setuptools: affected < 78.1.1; fixed in 78.1.1

## Suggested inspection (read-only)
- `python -m pip show setuptools`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on setuptools.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5rjg-fvgr-3xxf (OSV record GHSA-5rjg-fvgr-3xxf lists affected ranges: PyPI setuptools >=0 <78.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-5rjg-fvgr-3xxf (GitHub-reviewed advisory GHSA-5rjg-fvgr-3xxf lists affected ranges: PyPI setuptools >=0 <78.1.1)

Commands are suggestions: review each one before running it.

Loading voting…