Browser Use allows bypassing allowed_domains by putting a decoy domain in http auth username portion of a URL
CVE-2025-47241GHSA-x39x-9qw5-ghrf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (browser-use 0.1.45), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI browser-use
- Affected
- < 0.1.45
- Fixed in
- 0.1.45
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x39x-9qw5-ghrf lists affected ranges: PyPI browser-use >=0 <0.1.45 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x39x-9qw5-ghrf lists affected ranges: PyPI browser-use >=0 <=0.1.44
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L
- EPSS
- CVE-2025-47241: 0.46% estimated exploitation activity in the next 30 days; percentile 40.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary During a manual source code review, ARIMLABS.AI researchers identified that the `browser_use` module includes an embedded whitelist functionality to restrict URLs that can be visited. This restriction is enforced during agent initialization. However, it was discovered that these measures can be bypassed, leading to severe security implications.
Details File: `browser_use/browser/context.py` The `BrowserContextConfig` class defines an `allowed_domains` list, which is intended to limit accessible domains. This list is checked in the `_is_url_allowed()` method before navigation: ```python @dataclass class BrowserContextConfig: """ [STRIPPED] """ cookies_file: str | None = None minimum_wait_page_load_time: float = 0.5 wait_for_network_idle_page_load_time: float = 1 maximum_wait_page_load_time: float = 5 wait_between_actions: float = 1 disable_security: bool = True browser_window_size: BrowserContextWindowSize = field(default_factory=lambda:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-x39x-9qw5-ghrf
- Revision 3 · amended ·
Amended from ghsa record GHSA-x39x-9qw5-ghrf
- Revision 2 · amended ·
Amended from ghsa record GHSA-x39x-9qw5-ghrf
- Revision 1 · created ·
Published from osv record GHSA-x39x-9qw5-ghrf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47241 Advisory: Browser Use allows bypassing `allowed_domains` by putting a decoy domain in http auth username portion of a URL IDs: CVE-2025-47241, GHSA-x39x-9qw5-ghrf Record: https://patchnext.com/advisories/cve-2025-47241 (revision 4, source checked 28 Oct 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: browser-use 0.1.45. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI browser-use: affected < 0.1.45; fixed in 0.1.45 ## Suggested inspection (read-only) - `python -m pip show browser-use`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on browser-use. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x39x-9qw5-ghrf (OSV record GHSA-x39x-9qw5-ghrf lists affected ranges: PyPI browser-use >=0 <0.1.45 (fixed)) - Verified: https://github.com/advisories/GHSA-x39x-9qw5-ghrf (GitHub-reviewed advisory GHSA-x39x-9qw5-ghrf lists affected ranges: PyPI browser-use >=0 <=0.1.44) Commands are suggestions: review each one before running it.
Loading voting…