Magneto contains stored XSS vulnerability
CVE-2025-47110GHSA-j934-vjh5-vf9r
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/community-edition
- Affected
- >= 2.4.8-beta1, < 2.4.8-p1>= 2.4.7-beta1, < 2.4.7-p6< 2.4.5-p13>= 2.4.7, <= 2.4.7>= 2.4.8, <= 2.4.8>= 2.4.5, <= 2.4.5>= 2.4.6-p1, < 2.4.6-p11>= 2.4.6, <= 2.4.6
- Fixed in
- 2.4.5-p13, 2.4.7-p6, 2.4.8-p1, 2.4.6-p11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j934-vjh5-vf9r lists affected ranges: Packagist magento/community-edition >=2.4.8-beta1 =2.4.7-beta1 =0 =2.4.7 =2.4.8 =2.4.5 =2.4.6-p1 =2.4.6 <=2.4.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-47110: 0.73% estimated exploitation activity in the next 30 days; percentile 54.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Magento versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j934-vjh5-vf9r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47110 Advisory: Magneto contains stored XSS vulnerability IDs: CVE-2025-47110, GHSA-j934-vjh5-vf9r Record: https://patchnext.com/advisories/cve-2025-47110 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/community-edition: affected >= 2.4.8-beta1, < 2.4.8-p1; >= 2.4.7-beta1, < 2.4.7-p6; < 2.4.5-p13; >= 2.4.7, <= 2.4.7; >= 2.4.8, <= 2.4.8; >= 2.4.5, <= 2.4.5; >= 2.4.6-p1, < 2.4.6-p11; >= 2.4.6, <= 2.4.6; fixed in 2.4.5-p13, 2.4.7-p6, 2.4.8-p1, 2.4.6-p11 ## Suggested inspection (read-only) - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j934-vjh5-vf9r (GitHub-reviewed advisory GHSA-j934-vjh5-vf9r lists affected ranges: Packagist magento/community-edition >=2.4.8-beta1 =2.4.7-beta1 =0 =2.4.7 =2.4.8 =2.4.5 =2.4.6-p1 =2.4.6 <=2.4.6) Commands are suggestions: review each one before running it.
Loading voting…