Skip to content

← Actionable
Medium, CVSS 6.4

league/commonmark contains a XSS vulnerability in Attributes extension

CVE-2025-46734GHSA-3527-qv2q-pfvx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (league/commonmark 2.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2025-46734: 0.38% estimated exploitation activity in the next 30 days; percentile 31.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Cross-site scripting (XSS) vulnerability in the Attributes extension of the league/commonmark library (versions 1.5.0 through 2.6.x) allows remote attackers to insert malicious JavaScript calls into HTML. Details The league/commonmark library provides configuration options such as htmlinput: 'strip' and allowunsafelinks: false to mitigate cross-site scripting (XSS) attacks by stripping raw HTML and disallowing unsafe links. However, when the Attributes Extension is enabled, it introduces a way for users to inject arbitrary HTML attributes into elements via Markdown syntax using curly braces. As a result, even with the secure configuration shown above, an attacker can inject dangerous attributes into applications using this extension via a payload such as: Which results in the following HTML: Which causes the JS to execute immediately on page load. Patches Version 2.7.0 contains three changes to prevent this XSS attack vector: - All attributes starting with on are considered…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3527-qv2q-pfvx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46734

Advisory: league/commonmark contains a XSS vulnerability in Attributes extension
IDs: CVE-2025-46734, GHSA-3527-qv2q-pfvx
Record: https://patchnext.com/advisories/cve-2025-46734 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: league/commonmark 2.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist league/commonmark: affected >= 1.5.0, < 2.7.0; fixed in 2.7.0

## Suggested inspection (read-only)
- Packagist league/commonmark: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on league/commonmark.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3527-qv2q-pfvx (GitHub-reviewed advisory GHSA-3527-qv2q-pfvx lists affected ranges: Packagist league/commonmark >=1.5.0 <2.7.0)

Commands are suggestions: review each one before running it.

Loading voting…