Skip to content

← Actionable
High, CVSS 7.3

Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI

CVE-2025-46731GHSA-7c58-g782-9j38

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.6.15, 4.14.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 4.0.0-RC1, <= 4.14.12>= 5.0.0-RC1, <= 5.6.14
    Fixed in
    5.6.15, 4.14.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-46731: 1.52% estimated exploitation activity in the next 30 days; percentile 74.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Craft CMS contains a potential remote code execution vulnerability via Twig SSTI. You must have administrator access and ALLOWADMINCHANGES must be enabled for this to work. https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production Note: This is a follow-up to https://github.com/craftcms/cms/security/advisories/GHSA-f3cw-hg6r-chfv Users should update to the patched versions (4.14.13 and 5.6.15) to mitigate the issue. References https://github.com/craftcms/cms/pull/17026

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7c58-g782-9j38

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46731

Advisory: Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI
IDs: CVE-2025-46731, GHSA-7c58-g782-9j38
Record: https://patchnext.com/advisories/cve-2025-46731 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.6.15, 4.14.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 4.0.0-RC1, <= 4.14.12; >= 5.0.0-RC1, <= 5.6.14; fixed in 5.6.15, 4.14.13

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7c58-g782-9j38 (GitHub-reviewed advisory GHSA-7c58-g782-9j38 lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <=5.6.14)

Commands are suggestions: review each one before running it.

Loading voting…