Skip to content

← Actionable
High, CVSS 7.5

Rack has an Unbounded-Parameter DoS in Rack::QueryParser

CVE-2025-46727GHSA-gjh7-p2fx-99vx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.1.14, 3.0.16, 2.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rack

    Affected
    < 2.2.14>= 3.0, < 3.0.16>= 3.1, < 3.1.14
    Fixed in
    3.0.16, 2.2.14, 3.1.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-46727: 1.21% estimated exploitation activity in the next 30 days; percentile 68.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Rack::QueryParser parses query strings and application/x-www-form-urlencoded bodies into Ruby data structures without imposing any limit on the number of parameters, allowing attackers to send requests with extremely large numbers of parameters. Details The vulnerability arises because Rack::QueryParser iterates over each &-separated key-value pair and adds it to a Hash without enforcing an upper bound on the total number of parameters. This allows an attacker to send a single request containing hundreds of thousands (or more) of parameters, which consumes excessive memory and CPU during parsing. Impact An attacker can trigger denial of service by sending specifically crafted HTTP requests, which can cause memory exhaustion or pin CPU resources, stalling or crashing the Rack server. This results in full service disruption until the affected worker is restarted. Mitigation - Update to a version of Rack that limits the number of parameters parsed, or - Use middleware to enforce…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gjh7-p2fx-99vx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46727

Advisory: Rack has an Unbounded-Parameter DoS in Rack::QueryParser
IDs: CVE-2025-46727, GHSA-gjh7-p2fx-99vx
Record: https://patchnext.com/advisories/cve-2025-46727 (revision 1, source checked 26 Oct 2026, 15:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack 3.1.14, 3.0.16, 2.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack: affected < 2.2.14; >= 3.0, < 3.0.16; >= 3.1, < 3.1.14; fixed in 3.0.16, 2.2.14, 3.1.14

## Suggested inspection (read-only)
- RubyGems rack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gjh7-p2fx-99vx (GitHub-reviewed advisory GHSA-gjh7-p2fx-99vx lists affected ranges: RubyGems rack >=0 =3.0 =3.1 <3.1.14)

Commands are suggestions: review each one before running it.

Loading voting…