Langroid Allows XXE Injection via XMLToolMessage
CVE-2025-46726GHSA-pw95-88fg-3j6f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langroid 0.53.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langroid
- Affected
- < 0.53.4
- Fixed in
- 0.53.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pw95-88fg-3j6f lists affected ranges: PyPI langroid >=0 <0.53.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pw95-88fg-3j6f lists affected ranges: PyPI langroid >=0 <0.53.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-46726: 0.65% estimated exploitation activity in the next 30 days; percentile 51.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A LLM application leveraging XMLToolMessage class may be exposed to untrusted XML input that could result in DoS and/or exposing local files with sensitive information. Details XMLToolMessage uses lxml without safeguards: https://github.com/langroid/langroid/blob/df6227e6c079ec22bb2768498423148d6685acff/langroid/agent/xmltoolmessage.py#L51-L52 lxml is vulnerable to quadratic blowup attacks and processes external entity declarations for local files by default. Check here: https://pypi.org/project/defusedxml/#python-xml-libraries PoC A typical Quadratic blowup XML payload looks like this: Here, &a; expands to 10 characters, &b; expands to 100, and &c; expands to 1000, causing exponential memory usage and potentially crashing the application. Fix Langroid 0.53.4 initializes XMLParser with flags to prevent XML External Entity (XXE), billion laughs, and external DTD attacks by disabling entity resolution, DTD loading, and network access.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pw95-88fg-3j6f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pw95-88fg-3j6f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-46726 Advisory: Langroid Allows XXE Injection via XMLToolMessage IDs: CVE-2025-46726, GHSA-pw95-88fg-3j6f Record: https://patchnext.com/advisories/cve-2025-46726 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langroid 0.53.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langroid: affected < 0.53.4; fixed in 0.53.4 ## Suggested inspection (read-only) - `python -m pip show langroid`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langroid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pw95-88fg-3j6f (OSV record GHSA-pw95-88fg-3j6f lists affected ranges: PyPI langroid >=0 <0.53.4 (fixed)) - Verified: https://github.com/advisories/GHSA-pw95-88fg-3j6f (GitHub-reviewed advisory GHSA-pw95-88fg-3j6f lists affected ranges: PyPI langroid >=0 <0.53.4) Commands are suggestions: review each one before running it.
Loading voting…