Skip to content

← Actionable
Medium, CVSS 4.2amended

vLLM has a Weakness in MultiModalHasher Image Hashing Implementation

CVE-2025-46722GHSA-c65p-x677-fgj6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.7.0, < 0.9.0
    Fixed in
    0.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:L
EPSS
  • CVE-2025-46722: 0.34% estimated exploitation activity in the next 30 days; percentile 27.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In the file vllm/multimodal/hasher.py, the MultiModalHasher class has a security and data integrity issue in its image hashing method. Currently, it serializes PIL.Image.Image objects using only obj.tobytes(), which returns only the raw pixel data, without including metadata such as the image’s shape (width, height, mode). As a result, two images of different sizes (e.g., 30x100 and 100x30) with the same pixel byte sequence could generate the same hash value. This may lead to hash collisions, incorrect cache hits, and even data leakage or security risks. Details - Affected file: vllm/multimodal/hasher.py - Affected method: MultiModalHasher.serializeitem https://github.com/vllm-project/vllm/blob/9420a1fc30af1a632bbc2c66eb8668f3af41f026/vllm/multimodal/hasher.py#L34-L35 - Current behavior: For Image.Image instances, only obj.tobytes() is used for hashing. - Problem description: obj.tobytes() does not include the image’s width, height, or mode metadata. - Impact: Two images with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c65p-x677-fgj6

  2. Revision 1 · created ·

    Published from osv record GHSA-c65p-x677-fgj6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46722

Advisory: vLLM has a Weakness in MultiModalHasher Image Hashing Implementation
IDs: CVE-2025-46722, GHSA-c65p-x677-fgj6
Record: https://patchnext.com/advisories/cve-2025-46722 (revision 2, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.7.0, < 0.9.0; fixed in 0.9.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c65p-x677-fgj6 (OSV record GHSA-c65p-x677-fgj6 lists affected ranges: PyPI vllm >=0.7.0 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-c65p-x677-fgj6 (GitHub-reviewed advisory GHSA-c65p-x677-fgj6 lists affected ranges: PyPI vllm >=0.7.0 <0.9.0)

Commands are suggestions: review each one before running it.

Loading voting…