Skip to content

← Actionable
Low, CVSS 3.3

sudo-rs Allows Low Privilege Users to Enumerate Privileges of Others

CVE-2025-46718GHSA-w9q3-g4p5-5q2r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sudo-rs 0.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io sudo-rs

    Affected
    < 0.2.6
    Fixed in
    0.2.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-46718: 0.27% estimated exploitation activity in the next 30 days; percentile 19.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Users with limited sudo privileges (e.g. execution of a single command) can list sudo privileges of other users using the -U flag. This doesn't happen with the original sudo. PoC The initial test has been done in a container running Ubuntu 24.04 and installing oxidizr, running sudo-rs 0.2.2. A user (bob) has been added with only ps command executable through sudo: The user is not able to read the /etc/sudoers file and running sudo -l -Uroot with original sudo (version 1.9.15p5) causes the following error: The same command with sudo-rs is run without denying the execution: The same happens for other non-root users: The behavior has been also been observed for version 0.2.5. Impact Users with limited sudo privileges can enumerate the sudoers file, revealing sensitive information about other users' permissions. Attackers can collect information that can be used to more targeted attacks. Systems where users either do not have sudo privileges or have the ability to run all…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w9q3-g4p5-5q2r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46718

Advisory: sudo-rs Allows Low Privilege Users to Enumerate Privileges of Others
IDs: CVE-2025-46718, GHSA-w9q3-g4p5-5q2r
Record: https://patchnext.com/advisories/cve-2025-46718 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sudo-rs 0.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io sudo-rs: affected < 0.2.6; fixed in 0.2.6

## Suggested inspection (read-only)
- crates.io sudo-rs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sudo-rs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w9q3-g4p5-5q2r (GitHub-reviewed advisory GHSA-w9q3-g4p5-5q2r lists affected ranges: crates.io sudo-rs >=0 <0.2.6)

Commands are suggestions: review each one before running it.

Loading voting…