Skip to content

← Actionable
Low, CVSS 2.9amended

markdownify allows large headline prefixes such as , which causes memory consumption

CVE-2025-46656GHSA-7mpr-5m44-h73r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (markdownify 0.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.9 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2025-46656: 0.22% estimated exploitation activity in the next 30 days; percentile 12.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

python-markdownify (aka markdownify) before 0.14.1 allows large headline prefixes such as <h9999999 in addition to <h1 through <h6. This causes memory consumption.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7mpr-5m44-h73r

  2. Revision 1 · created ·

    Published from osv record GHSA-7mpr-5m44-h73r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46656

Advisory: markdownify allows large headline prefixes such as , which causes memory consumption
IDs: CVE-2025-46656, GHSA-7mpr-5m44-h73r
Record: https://patchnext.com/advisories/cve-2025-46656 (revision 2, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: markdownify 0.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI markdownify: affected < 0.14.1; fixed in 0.14.1

## Suggested inspection (read-only)
- `python -m pip show markdownify`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on markdownify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7mpr-5m44-h73r (OSV record GHSA-7mpr-5m44-h73r lists affected ranges: PyPI markdownify >=0 <0.14.1 (fixed))
- Verified: https://github.com/advisories/GHSA-7mpr-5m44-h73r (GitHub-reviewed advisory GHSA-7mpr-5m44-h73r lists affected ranges: PyPI markdownify >=0 <0.14.1)

Commands are suggestions: review each one before running it.

Loading voting…