CNCF K3s Kubernetes kubelet configuration exposes credentials
CVE-2025-46599GHSA-864f-7xjm-2jp2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/k3s-io/k3s 1.32.4-rc1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.32.0-rc1, < 1.32.4-rc1
- Fixed in
- 1.32.4-rc1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-864f-7xjm-2jp2 lists affected ranges: Go github.com/k3s-io/k3s >=1.32.0-rc1 <1.32.4-rc1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2025-46599: 0.46% estimated exploitation activity in the next 30 days; percentile 39.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CNCF K3s 1.32 before 1.32.4-rc1+k3s1 has a Kubernetes kubelet configuration change with the unintended consequence that, in some situations, ReadOnlyPort is set to 10255. For example, the default behavior of a K3s online installation might allow unauthenticated access to this port, exposing credentials.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-864f-7xjm-2jp2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-46599 Advisory: CNCF K3s Kubernetes kubelet configuration exposes credentials IDs: CVE-2025-46599, GHSA-864f-7xjm-2jp2 Record: https://patchnext.com/advisories/cve-2025-46599 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/k3s-io/k3s 1.32.4-rc1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/k3s-io/k3s: affected >= 1.32.0-rc1, < 1.32.4-rc1; fixed in 1.32.4-rc1 ## Suggested inspection (read-only) - Go github.com/k3s-io/k3s: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/k3s-io/k3s. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-864f-7xjm-2jp2 (GitHub-reviewed advisory GHSA-864f-7xjm-2jp2 lists affected ranges: Go github.com/k3s-io/k3s >=1.32.0-rc1 <1.32.4-rc1) Commands are suggestions: review each one before running it.
Loading voting…