OPA server Data API HTTP path injection of Rego
CVE-2025-46569GHSA-6m8w-jc87-6cr7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/open-policy-agent/opa 1.4.0; github.com/open-policy-agent/opa/v1/server 1.4.0; github.com/open-policy-agent/opa/server 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/open-policy-agent/opa
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Go github.com/open-policy-agent/opa/v1/server
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Go github.com/open-policy-agent/opa/server
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6m8w-jc87-6cr7 lists affected ranges: Go github.com/open-policy-agent/opa/v1/server >=0 =0 =0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.4 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-46569: 0.54% estimated exploitation activity in the next 30 days; percentile 45.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When run as a server, OPA exposes an HTTP Data API for reading and writing documents. Requesting a virtual document through the Data API entails policy evaluation, where a Rego query containing a single data document reference is constructed from the requested path. This query is then used for policy evaluation. A HTTP request path can be crafted in a way that injects Rego code into the constructed query. The evaluation result cannot be made to return any other data than what is generated by the requested path, but this path can be misdirected, and the injected Rego code can be crafted to make the query succeed or fail; opening up for oracle attacks or, given the right circumstances, erroneous policy decision results. Furthermore, the injected code can be crafted to be computationally expensive, resulting in a Denial Of Service (DoS) attack. Users are only impacted if all of the following apply: OPA is deployed as a standalone server (rather than being used as a Go library)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6m8w-jc87-6cr7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-46569 Advisory: OPA server Data API HTTP path injection of Rego IDs: CVE-2025-46569, GHSA-6m8w-jc87-6cr7 Record: https://patchnext.com/advisories/cve-2025-46569 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/open-policy-agent/opa 1.4.0; github.com/open-policy-agent/opa/v1/server 1.4.0; github.com/open-policy-agent/opa/server 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/open-policy-agent/opa: affected < 1.4.0; fixed in 1.4.0 - Go github.com/open-policy-agent/opa/v1/server: affected < 1.4.0; fixed in 1.4.0 - Go github.com/open-policy-agent/opa/server: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - Go github.com/open-policy-agent/opa: check the installed version with your package manager. - Go github.com/open-policy-agent/opa/v1/server: check the installed version with your package manager. - Go github.com/open-policy-agent/opa/server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/open-policy-agent/opa, github.com/open-policy-agent/opa/v1/server, github.com/open-policy-agent/opa/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6m8w-jc87-6cr7 (GitHub-reviewed advisory GHSA-6m8w-jc87-6cr7 lists affected ranges: Go github.com/open-policy-agent/opa/v1/server >=0 =0 =0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…