Vault Community Edition rekey and recovery key operations can cause denial of service
CVE-2025-4656GHSA-fhc2-8qx8-6vj7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/vault 1.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.14.8, < 1.20.0
- Fixed in
- 1.20.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fhc2-8qx8-6vj7 lists affected ranges: Go github.com/hashicorp/vault >=1.14.8 <1.20.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L
- EPSS
- CVE-2025-4656: 0.27% estimated exploitation activity in the next 30 days; percentile 18.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vault Community and Vault Enterprise rekey and recovery key operations can lead to a denial of service due to uncontrolled cancellation by a Vault operator. This vulnerability (CVE-2025-4656) has been remediated in Vault Community Edition 1.20.0 and Vault Enterprise 1.20.0, 1.19.6, 1.18.11, 1.17.17, and 1.16.22.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fhc2-8qx8-6vj7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-4656 Advisory: Vault Community Edition rekey and recovery key operations can cause denial of service IDs: CVE-2025-4656, GHSA-fhc2-8qx8-6vj7 Record: https://patchnext.com/advisories/cve-2025-4656 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/vault 1.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/vault: affected >= 1.14.8, < 1.20.0; fixed in 1.20.0 ## Suggested inspection (read-only) - Go github.com/hashicorp/vault: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/vault. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fhc2-8qx8-6vj7 (GitHub-reviewed advisory GHSA-fhc2-8qx8-6vj7 lists affected ranges: Go github.com/hashicorp/vault >=1.14.8 <1.20.0) Commands are suggestions: review each one before running it.
Loading voting…