Skip to content

← Actionable
High, CVSS 8.4

Any user with view access to the XWiki space can change the authenticator

CVE-2025-46557GHSA-f9c6-2f9p-82jj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-security-authentication-ui 16.10.0-rc-1, 16.4.6, 15.10.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-f9c6-2f9p-82jj lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-authentication-ui >=15.3-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.10.0-rc-1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-46557: 0.58% estimated exploitation activity in the next 30 days; percentile 47.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A user who can access pages located in the XWiki space (by default, anyone) can access the page XWiki.Authentication.Administration and (unless an authenticator is set in xwiki.cfg) switch to another installed authenticator. Note that, by default, there is only one authenticator available (Standard XWiki Authenticator). So, if no authenticator extension was installed, it's not really possible to do anything for an attacker. Also, in most cases, if you have installed and are using an SSO authenticator (like OIDC or LDAP for example), the worst an attacker can do is break authentication by switching back to the standard authenticator (that's because it's impossible to login to a user which does not have a stored password, and that's usually what SSO authenticator produce). Patches This has been patched in XWiki 15.10.9 and XWiki 16.3.0RC1. Workarounds You can very easily fix this vulnerability in your instance through right configuration: access the page and children right…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f9c6-2f9p-82jj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46557

Advisory: Any user with view access to the XWiki space can change the authenticator
IDs: CVE-2025-46557, GHSA-f9c6-2f9p-82jj
Record: https://patchnext.com/advisories/cve-2025-46557 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-security-authentication-ui 16.10.0-rc-1, 16.4.6, 15.10.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-security-authentication-ui: affected >= 15.3-rc-1, < 15.10.14; >= 16.0.0-rc-1, < 16.4.6; >= 16.5.0-rc-1, < 16.10.0-rc-1; fixed in 16.10.0-rc-1, 15.10.14, 16.4.6

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-security-authentication-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-security-authentication-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f9c6-2f9p-82jj (GitHub-reviewed advisory GHSA-f9c6-2f9p-82jj lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security-authentication-ui >=15.3-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.10.0-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…