Skip to content

← Actionable
Medium, CVSS 5.7

JRuby-OpenSSL has hostname verification disabled by default

CVE-2025-46551GHSA-72qj-48g4-5xgx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jruby:jruby 10.0.0.1, 9.4.12.1; rubygems:jruby-openssl 0.15.4; jruby-openssl 0.15.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-46551: 0.20% estimated exploitation activity in the next 30 days; percentile 9.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When verifying SSL certificates, jruby-openssl is not verifying that the hostname presented in the certificate matches the one we are trying to connect to, meaning a MITM could just present any valid cert for a completely different domain they own, and JRuby wouldn't complain. Details n/a PoC An example domain bad.substitutealert.com was created to present the a certificate for the domain s8a.me. The following script run in IRB in CRuby 3.4.3 will fail with certificate verify failed (hostname mismatch), but will work just fine in JRuby 10.0.0.0 and JRuby 9.4.2.0, both of which use jruby-openssl version 0.15.3 Impact Anybody using JRuby to make requests of external APIs, or scraping the web, that depends on https to connect securely

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-72qj-48g4-5xgx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46551

Advisory: JRuby-OpenSSL has hostname verification disabled by default
IDs: CVE-2025-46551, GHSA-72qj-48g4-5xgx
Record: https://patchnext.com/advisories/cve-2025-46551 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jruby:jruby 10.0.0.1, 9.4.12.1; rubygems:jruby-openssl 0.15.4; jruby-openssl 0.15.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jruby:jruby: affected >= 10.0.0.0, < 10.0.0.1; >= 9.3.4.0, < 9.4.12.1; fixed in 9.4.12.1, 10.0.0.1
- Maven rubygems:jruby-openssl: affected >= 0.12.1, < 0.15.4; fixed in 0.15.4
- RubyGems jruby-openssl: affected >= 0.12.1, < 0.15.4; fixed in 0.15.4

## Suggested inspection (read-only)
- Maven org.jruby:jruby: check the installed version with your package manager.
- Maven rubygems:jruby-openssl: check the installed version with your package manager.
- RubyGems jruby-openssl: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jruby:jruby, rubygems:jruby-openssl, jruby-openssl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-72qj-48g4-5xgx (GitHub-reviewed advisory GHSA-72qj-48g4-5xgx lists affected ranges: Maven rubygems:jruby-openssl >=0.12.1 =10.0.0.0 =9.3.4.0 =0.12.1 <0.15.4)

Commands are suggestions: review each one before running it.

Loading voting…