Skip to content

← Actionable
Critical, CVSS 10.0

YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download

CVE-2025-46348GHSA-wc9g-6j9w-hr95

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yeswiki/yeswiki 4.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-46348: 0.66% estimated exploitation activity in the next 30 days; percentile 51.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The request to commence a site backup can be performed without authentication. Then these backups can also be downloaded without authentication. The archives are created with a predictable filename, so a malicious user could create an archive and then download the archive without being authenticated. Details Create an installation using the instructions found in the docker folder of the repository, setup the site, and then send the request to create an archive, which you do not need to be authenticated for: Then to retrieve it, make a simple GET request like to the correct URL: A malicious attacker could simply fuzz this filename. PoC Here is a python script to fuzz this: Impact Denial of Service - A malicious attacker could simply make numerous requests to create archives and fill up the file system with archives. Site Compromise - A malicious attacker can download the archive which will contain sensitive site information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wc9g-6j9w-hr95

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46348

Advisory: YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download
IDs: CVE-2025-46348, GHSA-wc9g-6j9w-hr95
Record: https://patchnext.com/advisories/cve-2025-46348 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yeswiki/yeswiki 4.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yeswiki/yeswiki: affected <= 4.5.3; fixed in 4.5.4

## Suggested inspection (read-only)
- Packagist yeswiki/yeswiki: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yeswiki/yeswiki.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wc9g-6j9w-hr95 (GitHub-reviewed advisory GHSA-wc9g-6j9w-hr95 lists affected ranges: Packagist yeswiki/yeswiki >=0 <=4.5.3)

Commands are suggestions: review each one before running it.

Loading voting…