Skip to content

← Actionable
High, CVSS 7.4

YesWiki Remote Code Execution via Arbitrary PHP File Write and Execution

CVE-2025-46347GHSA-88xg-v53p-fpvf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yeswiki/yeswiki 4.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-46347: 1.05% estimated exploitation activity in the next 30 days; percentile 64.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An arbitrary file write can be used to write a file with a PHP extension, which then can be browsed to in order to execute arbitrary code on the server. All testing was performed on a local docker setup running the latest version of the application. PoC Proof of Concept Navigate to http://localhost:8085/?LookWiki which allows you to click Create a new Graphical configuration where you specify some parameters and then click Save. After clicking save, this request is made (most headers removed for clarity): This request writes the file test.css to disk with the contents (abbreviated) To exploit this, utilize a proxy tool to intercept the the first request and change the filename extension to .php and add arbitrary PHP code in for one of the request body parameters. e.g. primary-color=%3C%3Fphp+system%28%24GET%5B%27cmd%27%5D%29%3B+%3F%3E Now the file pizzapower.php is written to /var/www/html/custom/css-presets/pizzapower.php and it starts with this, where the PHP code is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-88xg-v53p-fpvf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46347

Advisory: YesWiki Remote Code Execution via Arbitrary PHP File Write and Execution
IDs: CVE-2025-46347, GHSA-88xg-v53p-fpvf
Record: https://patchnext.com/advisories/cve-2025-46347 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yeswiki/yeswiki 4.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yeswiki/yeswiki: affected <= 4.5.3; fixed in 4.5.4

## Suggested inspection (read-only)
- Packagist yeswiki/yeswiki: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yeswiki/yeswiki.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-88xg-v53p-fpvf (GitHub-reviewed advisory GHSA-88xg-v53p-fpvf lists affected ranges: Packagist yeswiki/yeswiki >=0 <=4.5.3)

Commands are suggestions: review each one before running it.

Loading voting…