Skip to content

← Actionable
Medium, CVSS 5.0amended

n8n Vulnerable to Stored XSS through Attachments View Endpoint

CVE-2025-46343GHSA-c8hm-hr8h-5xjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.90.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.90.0
    Fixed in
    1.90.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N
EPSS
  • CVE-2025-46343: 0.27% estimated exploitation activity in the next 30 days; percentile 19.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact n8n workflows can store and serve binary files, which are accessible to authenticated users. However, there was no restriction on the MIME type of uploaded files, and the MIME type could be controlled via a GET parameter. This allowed the server to respond with any MIME type, potentially enabling malicious content to be interpreted and executed by the browser. An authenticated attacker with member-level permissions could exploit this by uploading a crafted HTML file containing malicious JavaScript. When another user visits the binary data endpoint with the MIME type set to text/html, the script executes in the context of the user’s session. This script could, for example, send a request to change the user’s email address in their account settings, effectively enabling account takeover. Patches - n8n@1.90.0 Credit We would like to thank @Mahmoud0x00 for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c8hm-hr8h-5xjw

  2. Revision 1 · created ·

    Published from osv record GHSA-c8hm-hr8h-5xjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46343

Advisory: n8n Vulnerable to Stored XSS through Attachments View Endpoint
IDs: CVE-2025-46343, GHSA-c8hm-hr8h-5xjw
Record: https://patchnext.com/advisories/cve-2025-46343 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 1.90.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.90.0; fixed in 1.90.0

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c8hm-hr8h-5xjw (OSV record GHSA-c8hm-hr8h-5xjw lists affected ranges: npm n8n >=0 <1.90.0 (fixed))
- Verified: https://github.com/advisories/GHSA-c8hm-hr8h-5xjw (GitHub-reviewed advisory GHSA-c8hm-hr8h-5xjw lists affected ranges: npm n8n >=0 <1.90.0)

Commands are suggestions: review each one before running it.

Loading voting…