SQL injection in ADOdb PostgreSQL driver pg_insert_id() method
CVE-2025-46337GHSA-8x27-jwjr-8545
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (adodb/adodb-php 5.22.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist adodb/adodb-php
- Affected
- <= 5.22.8
- Fixed in
- 5.22.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8x27-jwjr-8545 lists affected ranges: Packagist adodb/adodb-php >=0 <=5.22.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
- EPSS
- CVE-2025-46337: 0.76% estimated exploitation activity in the next 30 days; percentile 55.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pginsertid() with user-supplied data. Note that the indicated Severity corresponds to a worst-case usage scenario. Impact PostgreSQL drivers (postgres64, postgres7, postgres8, postgres9). Patches Vulnerability is fixed in ADOdb 5.22.9 (11107d6d6e5160b62e05dff8a3a2678cf0e3a426). Workarounds Only pass controlled data to pginsertid() method's $fieldname parameter, or escape it with pgescapeidentifier() first. References - Issue https://github.com/ADOdb/ADOdb/issues/1070 - Blog post by Marco Nappi Credits Thanks to Marco Nappi (@mrcnpp) for reporting this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8x27-jwjr-8545
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-46337 Advisory: SQL injection in ADOdb PostgreSQL driver pg_insert_id() method IDs: CVE-2025-46337, GHSA-8x27-jwjr-8545 Record: https://patchnext.com/advisories/cve-2025-46337 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: adodb/adodb-php 5.22.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist adodb/adodb-php: affected <= 5.22.8; fixed in 5.22.9 ## Suggested inspection (read-only) - Packagist adodb/adodb-php: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on adodb/adodb-php. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8x27-jwjr-8545 (GitHub-reviewed advisory GHSA-8x27-jwjr-8545 lists affected ranges: Packagist adodb/adodb-php >=0 <=5.22.8) Commands are suggestions: review each one before running it.
Loading voting…