Skip to content

← Actionable
Low, CVSS 3.3amended

NodeJS Driver for Snowflake has race condition when checking access to Easy Logging configuration file

CVE-2025-46328GHSA-wmjq-jrm2-9wfr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (snowflake-sdk 2.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-46328: 0.17% estimated exploitation activity in the next 30 days; percentile 6.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Issue Snowflake discovered and remediated a vulnerability in the NodeJS Driver for Snowflake (“Driver”). When using the Easy Logging feature on Linux and macOS the Driver didn’t correctly verify the permissions of the logging configuration file, potentially allowing an attacker with local access to overwrite the configuration and gain control over logging level and output location. This vulnerability affects Driver versions 1.10.0 through 2.0.3. Snowflake fixed the issue in version 2.0.4. Vulnerability Details When using the Easy Logging feature on Linux and macOS the Driver reads logging configuration from a user-provided file. On Linux and macOS the Driver verifies that the configuration file can be written to only by its owner. That check was vulnerable to a Time-of-Check to Time-of-Use (TOCTOU) race condition and failed to verify that the file owner matches the user running the Driver. This could allow a local attacker with write access to the configuration file or the directory…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wmjq-jrm2-9wfr

  2. Revision 1 · created ·

    Published from osv record GHSA-wmjq-jrm2-9wfr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-46328

Advisory: NodeJS Driver for Snowflake has race condition when checking access to Easy Logging configuration file
IDs: CVE-2025-46328, GHSA-wmjq-jrm2-9wfr
Record: https://patchnext.com/advisories/cve-2025-46328 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: snowflake-sdk 2.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm snowflake-sdk: affected >= 1.10.0, <= 2.0.3; fixed in 2.0.4

## Suggested inspection (read-only)
- `npm ls snowflake-sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on snowflake-sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wmjq-jrm2-9wfr (OSV record GHSA-wmjq-jrm2-9wfr lists affected ranges: npm snowflake-sdk >=1.10.0 <2.0.4 (fixed))
- Verified: https://github.com/advisories/GHSA-wmjq-jrm2-9wfr (GitHub-reviewed advisory GHSA-wmjq-jrm2-9wfr lists affected ranges: npm snowflake-sdk >=1.10.0 <=2.0.3)

Commands are suggestions: review each one before running it.

Loading voting…