Solon Vulnerable to Directory Traversal
CVE-2025-46096GHSA-m63q-4hr8-5r5h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.noear:solon-faas-luffy 3.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.noear:solon-faas-luffy
- Affected
- >= 3.1.2, < 3.2.0
- Fixed in
- 3.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m63q-4hr8-5r5h lists affected ranges: Maven org.noear:solon-faas-luffy >=3.1.2 <3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-46096: 0.50% estimated exploitation activity in the next 30 days; percentile 43.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Directory Traversal vulnerability in solon v.3.1.2 allows a remote attacker to conduct XSS attacks via the solon-faas-luffy component
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m63q-4hr8-5r5h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-46096 Advisory: Solon Vulnerable to Directory Traversal IDs: CVE-2025-46096, GHSA-m63q-4hr8-5r5h Record: https://patchnext.com/advisories/cve-2025-46096 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.noear:solon-faas-luffy 3.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.noear:solon-faas-luffy: affected >= 3.1.2, < 3.2.0; fixed in 3.2.0 ## Suggested inspection (read-only) - Maven org.noear:solon-faas-luffy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.noear:solon-faas-luffy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m63q-4hr8-5r5h (GitHub-reviewed advisory GHSA-m63q-4hr8-5r5h lists affected ranges: Maven org.noear:solon-faas-luffy >=3.1.2 <3.2.0) Commands are suggestions: review each one before running it.
Loading voting…