Skip to content

← Actionable
High, CVSS 7.7

RAGAS has an Arbitrary File Read vulnerability

CVE-2025-45691GHSA-v2xr-wvrv-p969

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ragas 0.3.0rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ragas

    Affected
    >= 0.2.3, < 0.3.0rc1
    Fixed in
    0.3.0rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-45691: 0.61% estimated exploitation activity in the next 30 days; percentile 49.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An Arbitrary File Read vulnerability exists in the ImageTextPromptValue class in Exploding Gradients RAGAS v0.2.3 to v0.2.14. The vulnerability stems from improper validation and sanitization of URLs supplied in the retrievedcontexts parameter when handling multimodal inputs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v2xr-wvrv-p969

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-45691

Advisory: RAGAS has an Arbitrary File Read vulnerability
IDs: CVE-2025-45691, GHSA-v2xr-wvrv-p969
Record: https://patchnext.com/advisories/cve-2025-45691 (revision 1, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ragas 0.3.0rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ragas: affected >= 0.2.3, < 0.3.0rc1; fixed in 0.3.0rc1

## Suggested inspection (read-only)
- `python -m pip show ragas`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ragas.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v2xr-wvrv-p969 (GitHub-reviewed advisory GHSA-v2xr-wvrv-p969 lists affected ranges: PyPI ragas >=0.2.3 <0.3.0rc1)

Commands are suggestions: review each one before running it.

Loading voting…