protobuf-python has a potential Denial of Service issue
CVE-2025-4565GHSA-8qvm-5x2c-j2w7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (protobuf 6.31.1, 5.29.5, 4.25.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI protobuf
- Affected
- < 4.25.8>= 5.26.0rc1, < 5.29.5>= 6.30.0rc1, < 6.31.1
- Fixed in
- 5.29.5, 4.25.8, 6.31.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8qvm-5x2c-j2w7 lists affected ranges: PyPI protobuf >=0 =5.26.0rc1 =6.30.0rc1 <6.31.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8qvm-5x2c-j2w7 lists affected ranges: PyPI protobuf >=0 =5.26.0rc1 =6.30.0rc1 <6.31.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-4565: 0.26% estimated exploitation activity in the next 30 days; percentile 17.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Any project that uses Protobuf pure-Python backend to parse untrusted Protocol Buffers data containing an arbitrary number of recursive groups, recursive messages or a series of SGROUP tags can be corrupted by exceeding the Python recursion limit. Reporter: Alexis Challande, Trail of Bits Ecosystem Security Team ecosystem@trailofbits.com Affected versions: This issue only affects the pure-Python implementation of protobuf-python backend. This is the implementation when PROTOCOLBUFFERSPYTHONIMPLEMENTATION=python environment variable is set or the default when protobuf is used from Bazel or pure-Python PyPi wheels. CPython PyPi wheels do not use pure-Python by default. This is a Python variant of a previous issue affecting protobuf-java. Severity This is a potential Denial of Service. Parsing nested protobuf data creates unbounded recursions that can be abused by an attacker. Proof of Concept For reproduction details, please refer to the unit tests decodertest.py and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8qvm-5x2c-j2w7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8qvm-5x2c-j2w7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-4565 Advisory: protobuf-python has a potential Denial of Service issue IDs: CVE-2025-4565, GHSA-8qvm-5x2c-j2w7 Record: https://patchnext.com/advisories/cve-2025-4565 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: protobuf 6.31.1, 5.29.5, 4.25.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI protobuf: affected < 4.25.8; >= 5.26.0rc1, < 5.29.5; >= 6.30.0rc1, < 6.31.1; fixed in 5.29.5, 4.25.8, 6.31.1 ## Suggested inspection (read-only) - `python -m pip show protobuf`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on protobuf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8qvm-5x2c-j2w7 (OSV record GHSA-8qvm-5x2c-j2w7 lists affected ranges: PyPI protobuf >=0 =5.26.0rc1 =6.30.0rc1 <6.31.1 (fixed)) - Verified: https://github.com/advisories/GHSA-8qvm-5x2c-j2w7 (GitHub-reviewed advisory GHSA-8qvm-5x2c-j2w7 lists affected ranges: PyPI protobuf >=0 =5.26.0rc1 =6.30.0rc1 <6.31.1) Commands are suggestions: review each one before running it.
Loading voting…