Step CA Has Authorization Bypass in ACME and SCEP Provisioners
CVE-2025-44005GHSA-h8cp-697h-8c8p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/smallstep/certificates 0.29.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/smallstep/certificates
- Affected
- <= 0.28.4
- Fixed in
- 0.29.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h8cp-697h-8c8p lists affected ranges: Go github.com/smallstep/certificates >=0 <=0.28.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2025-44005: 9.09% estimated exploitation activity in the next 30 days; percentile 95.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A security fix is now available for Step CA that resolves a vulnerability affecting deployments configured with ACME and/or SCEP provisioners. All operators running these provisioners should upgrade to the latest release (v0.29.0) immediately. The issue was discovered and disclosed by a research team during a security review. There is no evidence of active exploitation. To limit exploitation risk during a coordinated disclosure window, we are withholding detailed technical information for now. A full write-up will be published in several weeks. --- Embargo List If your organization runs Step CA in production and would like advance, embargoed notification of future security updates, visit https://u.step.sm/disclosure to request inclusion on our embargo list. --- Acknowledgements This issue was identified and reported by Stephen Kubik of the Cisco Advanced Security Initiatives Group (ASIG) --- Stay safe, and thank you for helping us keep the ecosystem secure.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h8cp-697h-8c8p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-44005 Advisory: Step CA Has Authorization Bypass in ACME and SCEP Provisioners IDs: CVE-2025-44005, GHSA-h8cp-697h-8c8p Record: https://patchnext.com/advisories/cve-2025-44005 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/smallstep/certificates 0.29.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/smallstep/certificates: affected <= 0.28.4; fixed in 0.29.0 ## Suggested inspection (read-only) - Go github.com/smallstep/certificates: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/smallstep/certificates. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h8cp-697h-8c8p (GitHub-reviewed advisory GHSA-h8cp-697h-8c8p lists affected ranges: Go github.com/smallstep/certificates >=0 <=0.28.4) Commands are suggestions: review each one before running it.
Loading voting…