Vantage6 Server JWT secret not cryptographically secure
CVE-2025-43866GHSA-m3mq-f375-5vgh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vantage6-server 4.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vantage6-server
- Affected
- < 4.11.0
- Fixed in
- 4.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m3mq-f375-5vgh lists affected ranges: PyPI vantage6-server >=0 <4.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m3mq-f375-5vgh lists affected ranges: PyPI vantage6-server >=0 <4.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.7 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-43866: 0.39% estimated exploitation activity in the next 30 days; percentile 32.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The JWT secret key in the vantage6 server is auto-generated unless defined by the user. The auto-generated key is a UUID1, which is not cryptographically secure as it is predictable to some extent Patches No Workarounds You may define JWT secret key in the server configuration file
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m3mq-f375-5vgh
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m3mq-f375-5vgh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-43866 Advisory: Vantage6 Server JWT secret not cryptographically secure IDs: CVE-2025-43866, GHSA-m3mq-f375-5vgh Record: https://patchnext.com/advisories/cve-2025-43866 (revision 3, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vantage6-server 4.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vantage6-server: affected < 4.11.0; fixed in 4.11.0 ## Suggested inspection (read-only) - `python -m pip show vantage6-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vantage6-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m3mq-f375-5vgh (OSV record GHSA-m3mq-f375-5vgh lists affected ranges: PyPI vantage6-server >=0 <4.11.0 (fixed)) - Verified: https://github.com/advisories/GHSA-m3mq-f375-5vgh (GitHub-reviewed advisory GHSA-m3mq-f375-5vgh lists affected ranges: PyPI vantage6-server >=0 <4.11.0) Commands are suggestions: review each one before running it.
Loading voting…