Skip to content

← Actionable
High, CVSS 8.2amended

React Router allows pre-render data spoofing on React-Router framework mode

CVE-2025-43865GHSA-cpj6-fhp6-mr6j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-router 7.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm react-router

    Affected
    >= 7.0.0-pre.0, <= 7.5.1
    Fixed in
    7.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2025-43865: 0.81% estimated exploitation activity in the next 30 days; percentile 57.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary After some research, it turns out that it's possible to modify pre-rendered data by adding a header to the request. This allows to completely spoof its contents and modify all the values ​​of the data object passed to the HTML. Latest versions are impacted. Details The vulnerable header is X-React-Router-Prerender-Data, a specific JSON object must be passed to it in order for the spoofing to be successful as we will see shortly. Here is the vulnerable code : <img width="776" alt="Capture d’écran 2025-04-07 à 05 36 58" src="https://github.com/user-attachments/assets/c95b0b33-15ce-4d30-9f5e-b10525dd6ab4" / To use the header, React-router must be used in Framework mode, and for the attack to be possible the target page must use a loader. Steps to reproduce Versions used for our PoC: - "@react-router/node": "^7.5.0", - "@react-router/serve": "^7.5.0", - "react": "^19.0.0" - "react-dom": "^19.0.0" - "react-router": "^7.5.0" 1. Install React-Router with its default configuration…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cpj6-fhp6-mr6j

  2. Revision 1 · created ·

    Published from osv record GHSA-cpj6-fhp6-mr6j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-43865

Advisory: React Router allows pre-render data spoofing on React-Router framework mode
IDs: CVE-2025-43865, GHSA-cpj6-fhp6-mr6j
Record: https://patchnext.com/advisories/cve-2025-43865 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: react-router 7.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm react-router: affected >= 7.0.0-pre.0, <= 7.5.1; fixed in 7.5.2

## Suggested inspection (read-only)
- `npm ls react-router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on react-router.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cpj6-fhp6-mr6j (OSV record GHSA-cpj6-fhp6-mr6j lists affected ranges: npm react-router >=7.0.0-pre.0 <7.5.2 (fixed))
- Verified: https://github.com/advisories/GHSA-cpj6-fhp6-mr6j (GitHub-reviewed advisory GHSA-cpj6-fhp6-mr6j lists affected ranges: npm react-router >=7.0.0-pre.0 <=7.5.1)

Commands are suggestions: review each one before running it.

Loading voting…