React Router allows a DoS via cache poisoning by forcing SPA mode
CVE-2025-43864GHSA-f46r-rw29-r322
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-router 7.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm react-router
- Affected
- >= 7.2.0, <= 7.5.1
- Fixed in
- 7.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f46r-rw29-r322 lists affected ranges: npm react-router >=7.2.0 <7.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f46r-rw29-r322 lists affected ranges: npm react-router >=7.2.0 <=7.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-43864: 20.47% estimated exploitation activity in the next 30 days; percentile 97.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary After some research, it turns out that it is possible to force an application to switch to SPA mode by adding a header to the request. If the application uses SSR and is forced to switch to SPA, this causes an error that completely corrupts the page. If a cache system is in place, this allows the response containing the error to be cached, resulting in a cache poisoning that strongly impacts the availability of the application. Details The vulnerable header is X-React-Router-SPA-Mode; adding it to a request sent to a page/endpoint using a loader throws an error. Here is the vulnerable code : <img width="672" alt="Capture d’écran 2025-04-07 à 08 28 20" src="https://github.com/user-attachments/assets/0a0e9c41-70fd-4dba-9061-892dd6797291" / To use the header, React-router must be used in Framework mode, and for the attack to be possible the target page must use a loader. Steps to reproduce Versions used for our PoC: - "@react-router/node": "^7.5.0", - "@react-router/serve":…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f46r-rw29-r322
- Revision 1 · created ·
Published from osv record GHSA-f46r-rw29-r322
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-43864 Advisory: React Router allows a DoS via cache poisoning by forcing SPA mode IDs: CVE-2025-43864, GHSA-f46r-rw29-r322 Record: https://patchnext.com/advisories/cve-2025-43864 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: react-router 7.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm react-router: affected >= 7.2.0, <= 7.5.1; fixed in 7.5.2 ## Suggested inspection (read-only) - `npm ls react-router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on react-router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f46r-rw29-r322 (OSV record GHSA-f46r-rw29-r322 lists affected ranges: npm react-router >=7.2.0 <7.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-f46r-rw29-r322 (GitHub-reviewed advisory GHSA-f46r-rw29-r322 lists affected ranges: npm react-router >=7.2.0 <=7.5.1) Commands are suggestions: review each one before running it.
Loading voting…