AWS Amplify Studio UI Component Properties Has an Input Validation Issue
CVE-2025-4318GHSA-hf3j-86p7-mfw8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@aws-amplify/codegen-ui-react 2.20.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @aws-amplify/codegen-ui-react
- Affected
- <= 2.20.2
- Fixed in
- 2.20.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hf3j-86p7-mfw8 lists affected ranges: npm @aws-amplify/codegen-ui-react >=0 <=2.20.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hf3j-86p7-mfw8 lists affected ranges: npm @aws-amplify/codegen-ui-react >=0 <2.20.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-4318: 0.98% estimated exploitation activity in the next 30 days; percentile 62.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The AWS Amplify Studio amplify-codegen-ui is a package that generates front-end code from UI Builder entities (components, forms, views, and themes) primarily used in AWS Amplify Studio for component previews and in AWS Command Line Interface (AWS CLI) for generating component files in customers' local applications. An issue exists in the Amplify Studio property binding process of the amplify-codegen-ui package that could potentially allow an authenticated user to run arbitrary JavaScript code during the component rendering and build process. Impact When importing a component schema using the create-component command, Amplify Studio will import and generate the component on the users' behalf. The expression-binding function does not validate the component schema properties before converting them to expressions. As a result, an authenticated user who can create or modify components could run arbitrary JavaScript code during the component rendering and build process. Impacted…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-hf3j-86p7-mfw8
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-hf3j-86p7-mfw8
- Revision 1 · created ·
Published from ghsa record GHSA-hf3j-86p7-mfw8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-4318 Advisory: AWS Amplify Studio UI Component Properties Has an Input Validation Issue IDs: CVE-2025-4318, GHSA-hf3j-86p7-mfw8 Record: https://patchnext.com/advisories/cve-2025-4318 (revision 4, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @aws-amplify/codegen-ui-react 2.20.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @aws-amplify/codegen-ui-react: affected <= 2.20.2; fixed in 2.20.3 ## Suggested inspection (read-only) - `npm ls @aws-amplify/codegen-ui-react --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @aws-amplify/codegen-ui-react. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hf3j-86p7-mfw8 (GitHub-reviewed advisory GHSA-hf3j-86p7-mfw8 lists affected ranges: npm @aws-amplify/codegen-ui-react >=0 <=2.20.2) - Verified: https://osv.dev/vulnerability/GHSA-hf3j-86p7-mfw8 (OSV record GHSA-hf3j-86p7-mfw8 lists affected ranges: npm @aws-amplify/codegen-ui-react >=0 <2.20.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…