Skip to content

← Actionable
Medium, CVSS 5.1amended

MS SWIFT WEB-UI RCE Vulnerability

CVE-2025-41419GHSA-7c78-rm87-5673

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ms-swift 3.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ms-swift

    Affected
    < 3.7.0
    Fixed in
    3.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

I. Detailed Description: This includes scenarios, screenshots, vulnerability reproduction methods. For account-related vulnerabilities, please provide test accounts. If the reproduction process is complex, you may record a video, upload it to Taopan, and attach the link. 1. Install ms-swift 2. Start web-ui 3. After startup, access through browser at http://localhost:7860/ to see the launched fine-tuning framework program 4. Fill in necessary parameters In the LLM Training interface, fill in required parameters including Model id, Dataset Code. The --outputdir can be filled arbitrarily as it will be modified later through packet capture 5. Click Begin to start training. Capture packets and modify the parameter corresponding to --outputdir You can see the concatenated command being executed in the terminal where web-ui was started 6. Wait for the program to run (testing shows it requires at least 5 minutes), and you can observe the effect of command execution creating files II.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7c78-rm87-5673

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7c78-rm87-5673

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-41419

Advisory: MS SWIFT WEB-UI RCE Vulnerability
IDs: CVE-2025-41419, GHSA-7c78-rm87-5673
Record: https://patchnext.com/advisories/cve-2025-41419 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ms-swift 3.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ms-swift: affected < 3.7.0; fixed in 3.7.0

## Suggested inspection (read-only)
- `python -m pip show ms-swift`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ms-swift.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7c78-rm87-5673 (OSV record GHSA-7c78-rm87-5673 lists affected ranges: PyPI ms-swift >=0 <3.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7c78-rm87-5673 (GitHub-reviewed advisory GHSA-7c78-rm87-5673 lists affected ranges: PyPI ms-swift >=0 <3.7.0)

Commands are suggestions: review each one before running it.

Loading voting…