Spring Cloud Gateway Server Webflux is vulnerable to Expression Language Injection
CVE-2025-41253GHSA-fwxx-wv44-7qfg
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.cloud:spring-cloud-gateway-server
- Affected
- >= 4.3.0, < 4.3.2>= 4.2.0, < 4.2.6>= 4.0.0, <= 4.1.9<= 3.1.10
- Fixed in
- 4.3.2, 4.2.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fwxx-wv44-7qfg lists affected ranges: Maven org.springframework.cloud:spring-cloud-gateway-server >=4.3.0 =4.2.0 =4.0.0 =0 <=3.1.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-41253: 0.48% estimated exploitation activity in the next 30 days; percentile 41.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The following versions of Spring Cloud Gateway Server Webflux may be vulnerable to the ability to expose environment variables and system properties to attackers. An application should be considered vulnerable when all the following are true: The application is using Spring Cloud Gateway Server Webflux (Spring Cloud Gateway Server WebMVC is not vulnerable). An admin or untrusted third party using Spring Expression Language (SpEL) to access environment variables or system properties via routes. An untrusted third party could create a route that uses SpEL to access environment variables or system properties if: The Spring Cloud Gateway Server Webflux actuator web endpoint is enabled via management.endpoints.web.exposure.include=gateway and management.endpoint.gateway.enabled=trueor management.endpoint.gateway.access=unrestricte. The actuator endpoints are available to attackers. The actuator endpoints are unsecured.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fwxx-wv44-7qfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-41253 Advisory: Spring Cloud Gateway Server Webflux is vulnerable to Expression Language Injection IDs: CVE-2025-41253, GHSA-fwxx-wv44-7qfg Record: https://patchnext.com/advisories/cve-2025-41253 (revision 1, source checked 26 Oct 2026, 16:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.springframework.cloud:spring-cloud-gateway-server 4.3.2, 4.2.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.cloud:spring-cloud-gateway-server: affected >= 4.3.0, < 4.3.2; >= 4.2.0, < 4.2.6; >= 4.0.0, <= 4.1.9; <= 3.1.10; fixed in 4.3.2, 4.2.6 ## Suggested inspection (read-only) - Maven org.springframework.cloud:spring-cloud-gateway-server: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.cloud:spring-cloud-gateway-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fwxx-wv44-7qfg (GitHub-reviewed advisory GHSA-fwxx-wv44-7qfg lists affected ranges: Maven org.springframework.cloud:spring-cloud-gateway-server >=4.3.0 =4.2.0 =4.0.0 =0 <=3.1.10) Commands are suggestions: review each one before running it.
Loading voting…