Skip to content

← Actionable
Medium, CVSS 5.9amended

CodeChecker has a buffer overflow in the log command

CVE-2025-40843GHSA-5xf2-f6ch-6p8r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (codechecker 6.26.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2025-40843: 0.19% estimated exploitation activity in the next 30 days; percentile 8.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary CodeChecker versions up to 6.26.1 contain a buffer overflow vulnerability in the internal ldlogger library, which is executed by the CodeChecker log command. Details Unsafe usage of strcpy() function in the internal ldlogger library allows attackers to trigger a buffer overflow by supplying crafted inputs from the command line. Specifically, the destination buffer is stack-allocated with a fixed size of 4096 bytes, while strcpy() is called without any length checks, enabling an attacker to overrun the buffer. PoC Example script is included below to illustrate how this vulnerability can be exploited. Impact Any environment where the vulnerable CodeChecker log command is executed with untrusted user input is affected by this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5xf2-f6ch-6p8r

  2. Revision 1 · created ·

    Published from osv record GHSA-5xf2-f6ch-6p8r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-40843

Advisory: CodeChecker has a buffer overflow in the log command
IDs: CVE-2025-40843, GHSA-5xf2-f6ch-6p8r
Record: https://patchnext.com/advisories/cve-2025-40843 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: codechecker 6.26.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI codechecker: affected <= 6.26.1; fixed in 6.26.2

## Suggested inspection (read-only)
- `python -m pip show codechecker`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codechecker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5xf2-f6ch-6p8r (OSV record GHSA-5xf2-f6ch-6p8r lists affected ranges: PyPI codechecker >=0 <6.26.2 (fixed))
- Verified: https://github.com/advisories/GHSA-5xf2-f6ch-6p8r (GitHub-reviewed advisory GHSA-5xf2-f6ch-6p8r lists affected ranges: PyPI codechecker >=0 <=6.26.1)

Commands are suggestions: review each one before running it.

Loading voting…