Skip to content

← Actionable
Medium, CVSS 6.3amended

Strapi is vulnerable to Insufficient Session Expiration

CVE-2025-3930GHSA-4r8w-3jww-m2rp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/strapi 5.24.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-3930: 0.69% estimated exploitation activity in the next 30 days; percentile 53.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, which allows an attacker who has stolen or intercepted the token to freely reuse it until its expiration date (which is set to 30 days by default, but can be changed). The existence of /admin/renew-token endpoint allows anyone to renew near-expiration tokens indefinitely, further increasing the impact of this attack. This issue has been fixed in version 5.24.1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4r8w-3jww-m2rp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4r8w-3jww-m2rp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-3930

Advisory: Strapi is vulnerable to Insufficient Session Expiration
IDs: CVE-2025-3930, GHSA-4r8w-3jww-m2rp
Record: https://patchnext.com/advisories/cve-2025-3930 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/strapi 5.24.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/strapi: affected < 5.24.1; fixed in 5.24.1

## Suggested inspection (read-only)
- `npm ls @strapi/strapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/strapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4r8w-3jww-m2rp (OSV record GHSA-4r8w-3jww-m2rp lists affected ranges: npm @strapi/strapi >=0 <5.24.1 (fixed))
- Verified: https://github.com/advisories/GHSA-4r8w-3jww-m2rp (GitHub-reviewed advisory GHSA-4r8w-3jww-m2rp lists affected ranges: npm @strapi/strapi >=0 <5.24.1)

Commands are suggestions: review each one before running it.

Loading voting…