Skip to content

← Actionable
Medium, CVSS 5.3

Mattermost improperly allows team administrators to modify team invites

CVE-2025-3913GHSA-4mmr-2w8p-whcr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.7.1, 10.6.3, 10.5.4, 9.11.13, 8.0.0-20250412152950-02c76784380a), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost/server/v8

    Affected
    >= 10.7.0-rc1, < 10.7.1>= 10.6.0-rc1, < 10.6.3>= 10.5.0-rc1, < 10.5.4>= 9.0.0-rc1, < 9.11.13< 8.0.0-20250412152950-02c76784380a
    Fixed in
    10.6.3, 10.5.4, 10.7.1, 8.0.0-20250412152950-02c76784380a, 9.11.13

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4mmr-2w8p-whcr lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.7.0-rc1 =10.6.0-rc1 =10.5.0-rc1 =9.0.0-rc1 =0 <8.0.0-20250412152950-02c76784380a

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-3913: 0.33% estimated exploitation activity in the next 30 days; percentile 25.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to properly validate permissions when changing team privacy settings, allowing team administrators without the 'invite user' permission to access and modify team invite IDs via the /api/v4/teams/:teamId/privacy endpoint.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4mmr-2w8p-whcr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-3913

Advisory: Mattermost improperly allows team administrators to modify team invites
IDs: CVE-2025-3913, GHSA-4mmr-2w8p-whcr
Record: https://patchnext.com/advisories/cve-2025-3913 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.7.1, 10.6.3, 10.5.4, 9.11.13, 8.0.0-20250412152950-02c76784380a. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected >= 10.7.0-rc1, < 10.7.1; >= 10.6.0-rc1, < 10.6.3; >= 10.5.0-rc1, < 10.5.4; >= 9.0.0-rc1, < 9.11.13; < 8.0.0-20250412152950-02c76784380a; fixed in 10.6.3, 10.5.4, 10.7.1, 8.0.0-20250412152950-02c76784380a, 9.11.13

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4mmr-2w8p-whcr (GitHub-reviewed advisory GHSA-4mmr-2w8p-whcr lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.7.0-rc1 =10.6.0-rc1 =10.5.0-rc1 =9.0.0-rc1 =0 <8.0.0-20250412152950-02c76784380a)

Commands are suggestions: review each one before running it.

Loading voting…