Skip to content

← Actionable
Low, CVSS 3.5amended

Transformers's Improper Input Validation vulnerability can be exploited through username injection

CVE-2025-3777GHSA-phhr-52qp-3mj4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (transformers 4.52.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-3777: 0.41% estimated exploitation activity in the next 30 days; percentile 34.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Hugging Face Transformers versions up to 4.49.0 are affected by an improper input validation vulnerability in the imageutils.py file. The vulnerability arises from insecure URL validation using the startswith() method, which can be bypassed through URL username injection. This allows attackers to craft URLs that appear to be from YouTube but resolve to malicious domains, potentially leading to phishing attacks, malware distribution, or data exfiltration. The issue is fixed in version 4.52.1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-phhr-52qp-3mj4

  2. Revision 1 · created ·

    Published from osv record GHSA-phhr-52qp-3mj4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-3777

Advisory: Transformers's Improper Input Validation vulnerability can be exploited through username injection
IDs: CVE-2025-3777, GHSA-phhr-52qp-3mj4
Record: https://patchnext.com/advisories/cve-2025-3777 (revision 2, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: transformers 4.52.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI transformers: affected < 4.52.1; fixed in 4.52.1

## Suggested inspection (read-only)
- `python -m pip show transformers`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on transformers.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-phhr-52qp-3mj4 (OSV record GHSA-phhr-52qp-3mj4 lists affected ranges: PyPI transformers >=0 <4.52.1 (fixed))
- Verified: https://github.com/advisories/GHSA-phhr-52qp-3mj4 (GitHub-reviewed advisory GHSA-phhr-52qp-3mj4 lists affected ranges: PyPI transformers >=0 <4.52.1)

Commands are suggestions: review each one before running it.

Loading voting…